No internet connection
  1. Home
  2. Issues

Forum link embeds always show the title of the page, not the linked-to post

By Christian Scheuer @chrscheuer2020-10-26 18:52:58.612Z

If for example I want to link a user directly to a post inside a page, then the embed still shows the name and summary of the page, not the post.

See example:

https://forum.soundflow.org/-3232#post-4
  • 6 replies
  1. In reply tochrscheuer:
    KajMagnus @KajMagnus2020-10-31 08:41:00.097Z

    Good point. Maybe I can look into fixing this, and also starting to support inline link previews (so won't need to add all links in separate paragraphs, but can get title previews inline inside a paragraph) at the same time

    1. In reply tochrscheuer:
      KajMagnus @KajMagnus2021-01-02 13:00:53.085Z

      This should work now (will upgr Prod later today) — let's try, here's a link to my reply just above: (i.e. https://www.talkyard.io/-448#post-2)

      So now the text is from the reply: "Good point ...".

      The link preview title is still the topic title.
      Not sure if it'd be nice with a "reply nr 1" or "post 2" text somewhere. (Orig post = pos nr 1, the 1st reply = post nr 2)

      For example:

      Reply 1 on page The-Page-Title:
      
      Good point. Maybe I can   ...
      

      Or:

      Post 2 on page The-Page-Title:
      
      Good point. Maybe I can   ...
      
      1. CChristian Scheuer @chrscheuer2021-01-02 13:26:48.255Z

        This is super cool!

      2. Progress
        with handling this problem
      3. @KajMagnus marked this topic as Planned 2020-10-31 08:41:12.689Z.
      4. @KajMagnus marked this topic as Started 2021-01-02 13:01:16.900Z.
      5. @KajMagnus marked this topic as Done 2021-01-02 22:11:40.857Z.