No internet connection
  1. Home
  2. Support

Installation Question on Step 2: Prepare Ubuntu

By Mika MF @michaelmf2017-09-17 12:27:07.958Z

Hello!

I was following the instructions on GitHub to install Effective Discussions (https://github.com/debiki/ed-prod-one) and, upon running the command in step 2:

./scripts/prepare-ubuntu.sh 2>&1 | tee -a ed-maint.log

i got this screen, which i was unsure how to deal with:

For the sake of carrying on with it, i chose the highlighted option, which was highlighted by default. Was that the right thing to do?

Please let me know if there any other piece of information i might be able to provide you with.

Many thanks,
Mika

  • 3 replies
  1. KajMagnus @KajMagnus2017-09-18 14:40:33.891Z

    That option (the highlighted one) should be fine, and the first option too (i.e. install the package mainainer's version); in /etc/apt/apt.conf.d/20auto-upgrades we enable auto security upgrades, and i don't think the package managers are going to try to explicitly disable them by default in 50unattended-upgrades. So options 1 & 2 are both fine I think.

    I don't want that dialog to appear though :- P. I googled a bit and I think if I add DEBIAN_FRONTEND=noninteractive then the dialog will go away, and the old config file will be kept. So I'll add DEBIAN_FRONTEND=noninteractive to the script, and some time later I'll test if that'll work, thanks.

    1. Mika MF @michaelmf2017-10-04 07:40:57.635Z

      Hi KajMagnus,

      Thank you very much for the thorough reply!

      So, started over from Step 1, and got much of what i expected to see in that step --- roughly, that git was already installed, and it's already the newest version. I did not understand the "Ignoring file da-da-da" message, but carried on anyways. ( Please let me know if there's anything consequential about that message ;-) )

      When i reached Step 2, where i first had the question that started this thread, that screen did not show this time. You said you didn't want it to appear and that you were going to do something about it. I don't know if it did not appear this time because i had already run the script before, or if it's because something you may have done, so i figured i'd let you know.

      Thanks!
      Mika

      1. KajMagnus @KajMagnus2017-10-22 06:13:22.708Z

        Ok, i think maybe you won't see the dialog again, because the stuff has been installed already on the server.

        But I did add DEBIAN_FRONTEND=noninteractive so I think on new installations, the dialog also won't appear any longer.

        Closing this then. And thanks for the feedback / question, so I could fix this.