No internet connection
  1. Home
  2. Issues

Users unable to sign in

By Jeff M @phoenix2020-11-16 14:55:47.716Z

Hi,

For some reason, new users are unable to sign in this morning. They get this error:

Error 403 Forbidden
Participant 118 may not see page 39 [TyE305KDJW2]

When I look at the app logs, this is what occurs:

app_1 | DEBUG API request exception: ResultException [DwE4P7], site SiteBrief(1,ueggixa07m,Some(URL REMOVED ON PURPOSE BY JEFF),Active
), ip 10.2.0.5: /-/login-password-create-user kvs: null

Any ideas?

Thank you!

Jeff

  • 8 replies
  1. KajMagnus @KajMagnus2020-11-16 20:17:02.636Z

    A quick reply, I'll take a closer look tomorrow: It seems page 39 is not accessible to some people. If you go to this URL: https:// server address/-39 then you'll see which page is page 39. Then, look at the category it's in — is the category access restricted? (Should it be?)

    Anyway I think Talkyard should not show an error about this and prevent people from signing in.
    When I look at the source code, it looks as if Talkyard could just log a message about it without showing any error. ... I'll have a look tomorrow

    1. PJeff M @phoenix2020-11-16 20:36:42.092Z

      /-39 is a #support-chat Chat that is inside the Support category and it not access restricted.

      Thanks for looking into this.

    2. P
      In reply tophoenix:
      Jeff M @phoenix2020-11-16 20:39:32.755Z

      Note: As a test, I deleted the #support-chat topic I created and the problem went away, allowing sign-ups to resume without error. I then reenabled it and the error due to page 39 returned. I have disabled that support chat for now. ;)

      Thanks again!

      1. Progress
        with handling this problem
      2. @KajMagnus marked this topic as Started 2020-11-17 03:36:05.817Z.
      3. KajMagnus @KajMagnus2020-11-17 11:29:48.073Z

        Thanks for the additional info. Seems I can reproduce this:

        1) I create a new site, and make it login-required, and 2) create a chat channel and 3) pin it globally. Then, 4) when a new person signs up, this error happens. It's a bug, I've fixed it now, the fix will be in the upcoming version.

        1. P
          Jeff M @phoenix2020-11-17 14:49:52.898Zreplies toKajMagnus:

          OK. Great!

          1. P@phoenix marked this topic as Done 2020-11-17 14:50:04.037Z.
          2. KajMagnus @KajMagnus2020-11-26 22:07:13.140Z

            Now finally releasing the fix, i.e. a new server version. Your self hosted server should auto upgrade itself this night to the new version, v0.2020.30.