No internet connection
  1. Home
  2. Issues

Image Post - Error 403 Forbidden: Not logged in [TyE0LGDIN_]

By Jason M Cohen @akedomakona2021-03-02 18:43:04.727Z

I get the error Error 403 Forbidden: Not logged in [TyE0LGDIN_] when trying to add an image to a comment.
I am logged in and successfully post text.

Is there a way to fix this?

  • 9 replies
  1. KajMagnus @KajMagnus2021-03-02 20:20:05.540Z

    This is for blog comments?
    Are you logged in as yourself (a real user account), or as a guest (anonymous user, no password or email required)?

    I think I can have a look at this tomorrow.

    (Guest users by default cannot post images, however, the error message is weird)

    1. AJason M Cohen @akedomakona2021-03-02 20:26:05.988Z

      Yes, this is for blog comments;
      I am logged in as myself (admin).

      Thank you for taking a look!

      1. KajMagnus @KajMagnus2021-03-04 07:23:43.120Z

        Having a look now ... (ran out of time yesterday, sorry). Seems I've forgotten to include the session id, when uploading images from the embedded comments editor. — But not when uploading text and comments (so that works).

        Will most likely be fixed in the upcoming Ty version ...

        1. KajMagnus @KajMagnus2021-03-04 10:09:15.742Z

          Now fixed on localhost, just some code review & auto test left to do.

          I'd think a new version with this fixed, will be available at the end of the next week.

          (The underlying "problem" is that browser anti tracking features block the session id cookie,
          so the session id needs to be included in a custom HTTP header instead.)

          1. KajMagnus @KajMagnus2021-03-24 07:38:01.392Z

            Jason @akedomakona — The fix got deployed to Prod a week ago, Talkyard v0.2021.09. (Sorry for the a bit late status update.)

            So, now, if you want to, you could try uploading an image, over at your blog?

            (Next, I'll deploy to the self hosted installations too, today or tomorrow probably.)

            1. AJason M Cohen @akedomakona2021-03-25 21:31:33.745Z

              It works! Thank you so much!

              1. KajMagnus @KajMagnus2021-03-26 03:50:31.425Z

                Ok :- )  Thanks for checking

    2. Progress
      with handling this problem
    3. @KajMagnus marked this topic as Started 2021-03-04 10:11:28.044Z.
    4. @KajMagnus marked this topic as Done 2021-03-26 03:50:37.294Z.